Auteur Topic: Website laadt afbeeldingen traag  (gelezen 698 keer)

0 leden en 1 gast bekijken dit topic.

Offline Petert1453

  • Lid
  • *
  • Berichten: 3
  • Likes: +0/-0
Website laadt afbeeldingen traag
« Gepost op: zaterdag 25 december 2021, 00:38:53 »
Goedenavond,

Ik heb een hobby-website die ik met Wordpress heb gemaakt. Wanneer je naar de site surft merk je dat de afbeeldingen heel traag laden. Is er iemand die mij zou kunnen helpen (wat tips zou kunnen geven) om de site sneller te maken?

Als ik met Google (https://pagespeed.web.dev/) een speedtest uitvoer, krijg ik ook verschillende dingen te zien die verbeterd moeten worden, maar ik weet zelf niet precies hoe ik dit moet aanpakken.

Is er iemand die via wat PM-berichtjes me verder kan helpen? alvast bedankt!

Offline derkdejong

  • Expert Lid
  • *****
  • Berichten: 140
  • Likes: +5/-0
Re: Website laadt afbeeldingen traag
« Reactie #1 Gepost op: zaterdag 25 december 2021, 11:58:48 »
is dat alleen op je eigen pc het geval?
zo ja, begin dan eens met het weggooien van je opgeslagen internet bestanden.
omdat het juist de plaatjes zijn: hoe groot zijn die in omvang (kB's)
voor schermgebruik is doorgaans 400 kB voor grote afbeeldingen ruim voldoende, en voor kleinere weergaven dus nog minder....


Offline Hans

  • Administrator
  • *****
  • Berichten: 744
  • Likes: +11/-0
  • Geslacht: Man
Re: Website laadt afbeeldingen traag
« Reactie #2 Gepost op: zaterdag 25 december 2021, 18:08:43 »
Ik heb eens gekeken op je website maar vond het wel mee vallen met de snelheid ik neem aan dat je de plaatjes op die landkaart bedoeld in minder als 1 seconde staan ze er hier voor.
Ik neem aan dat als je op een van die icoontjes klikt en er een popup met foto verschijnt.

Offline Petert1453

  • Lid
  • *
  • Berichten: 3
  • Likes: +0/-0
Re: Website laadt afbeeldingen traag
« Reactie #3 Gepost op: zondag 26 december 2021, 01:07:23 »
Dank voor de reacties! Ik merk vooral dat hij sloom is als ik de cache op mijn PC heb leeggehaald en hij de site dus helemaal opnieuw moet laden (zoals anderen bij een eerste bezoek). De afbeeldingen upload ik naar de mediabibliotheek en door de plugin smush worden de afbeeldingen wat verkleind zodat die meestal rond de 400 tot 600 kb zijn (soms nog wel 1mb of zo). Ik dacht dat hiermee de afbeeldingen goed werden geüpload in de juiste formaten/indelingen maar bij Pagespeed Insights wordt aangegeven dat blijkbaar veel nog niet goed gaat ;)

Zie vooral dat "Lever afbeeldingen in moderne indelingen" en "Codeer afbeeldingen op een efficiënte manier" de laadtijd vergroot. Maar ik zie ook de melding "Unable to locate resource" bij diverse afbeeldingen. Ik weet niet of daar iets mee gedaan moet worden? Welke plugins zijn geschikt? Welke bestandstypen voor afbeeldingen? Blijft de kwaliteit van de foto's goed?

Voornamelijk de afbeeldingen onder de landkaart (de afbeeldingen in de carousel en de uitgelichte locaties) laden soms vrij sloom merk ik (had eerst nog wat meer afbeeldingen op de site staan maar die heb ik maar verwijderd om hem sneller te maken). Waarschijnlijk worden eerst alle foto's van de kaart geladen (die inderdaad verschijnen als je op een icoontje klikt maar die ook in de carousel onder de kaart verschijnen) wat misschien veel tijd kost.

Wat valt jullie op als je de speedtestresultaten bekijkt en wat raden jullie me aan te doen? ;)

Offline Petert1453

  • Lid
  • *
  • Berichten: 3
  • Likes: +0/-0
Re: Website laadt afbeeldingen traag
« Reactie #4 Gepost op: zondag 26 december 2021, 14:52:51 »
Ik las dat het verstandig is om afbeeldingen te converteren naar webp formaten omdat die kleiner en moderner zijn. Dit heb ik gedaan met Ewww image optimizer.

Wanneer ik bij mijn hostingprovider inlog zie ik nu dat alle afbeeldingen ook in webp zijn aangemaakt. Als ik echter in mijn fotobibliotheek in wordpress kijk staat alles nog in Jpeg/JPG/PNG. Ook als ik op de site een afbeelding open en opsla (via Chrome) is dit een Jpeg/JPG/PNG bestand.

Heeft dit converteren nu iets opgeleverd of moet ik nog iets aanvullends doen? Ik dacht dat Chrome Webp afbeeldingen kon laden, waardoor ik nu WebP bestanden zou moeten zien. Wat doe ik verkeerd? ;)

 

https://www.kwf.nl/
https://www.alzheimer-nederland.nl/